Back to overview
Resolved
Beacon Hosting EU2 & Panel Outage
Aug 24, 2026 at 10:00pm UTC
Affected services
beaconhosting.org
EU2
Resolved
Aug 24, 2026 at 10:28pm UTC
The Beacon Hosting Panel & EU2 are now available.
We will continue to monitor the situation.
Affected services
Created
Aug 24, 2026 at 10:00pm UTC
The Beacon Hosting Panel & EU2 is currently unavailable. We are actively investigating the issue and working to restore service as quickly as possible.
Affected services